Go Back   Truck Forums > Chevrolet/GMC Truck Forums > Chevy Silverado/ GMC Sierra Forum
Sign in using an external account
Register Forgot Password?
Search

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 10-19-2009, 11:33 PM
Junior Member
 
Join Date: Oct 2009
Posts: 2
Default 03 5.3L bogging down on heavy acceleration

I have a 2003 Sierra 5.3L that bogs down only on heavy acceleration, under gentle acceleration works fine, felt like a Cat to me, tempature tested it, right cat tested at a lower temp behind the cat, indicating to me that the cat was clogged due to no chemical reaction happening in the cat (i do not have a exhaust back pressure gauge handy). replaced the cat, code comes up (codes may have been there before, i didnt read them since one o2 sensor was broken and disconnected) codes are Bank 1 sensor 1 voltage low, Bank 2 sensor 1 voltage low. means its reading rich so im told. replaced the o2s incase faulty. still reads same codes. did a fuel pressure test, has good fuel pressure, does not drop with load.

throttle position sensor and MAP sensor appear to be working fine.

scanner wont read the EGR at all so not sure how to check that

My next step is to do a fuel volume test, ensure that 1L of fuel is being pumped out every 30 secs. possibly fuel pump and filter issue. not to sure

anyone else have any ideas?
This ad is not displayed to registered members.
Register your free account today and become a member on Truckforums!
Reply With Quote
  #2  
Old 10-20-2009, 07:10 PM
RUFFNECK4LYFE's Avatar
Toyota, Nissan, and Other Truck Forum Moderator
 
Join Date: May 2009
Location: West Texas
Posts: 1,845
Default

I think if the voltage is too low on those O2 sensors, that means its running lean. Check your Throttle Position Sensor.
__________________
That way you'll Learn!!!!
Reply With Quote
  #3  
Old 10-21-2009, 10:04 PM
Junior Member
 
Join Date: Oct 2009
Posts: 2
Default

ya your right, low voltage was lean, i should have taken the 30 seconds to look it up on the computer, would have saved me a lot of headache.
problem is solved, clogged fuel filter. so simple yet took a day to find that out.
Reply With Quote
Old 10-21-2009, 10:04 PM
 
 
 
Reply



Tags
2003, 53, 53l, back, bank, bogging, ford, gmc, low, pressure, sensor, sierra, sounds, throttle, truck, trucks, voltage

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising

Featured Sponsors
Vendor Directory

Our Sponsors
Advertising
All times are GMT -5. The time now is 02:47 AM.

Internet Brands, Inc.



SEO by vBSEO ©2010, Crawlability, Inc.