Go Back   Truck Forums > Chevrolet/GMC Truck Forums > Chevy Silverado/ GMC Sierra Forum
Sign in using an external account
Register Forgot Password?
Search

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 08-10-2011, 04:41 PM
Junior Member
 
Join Date: Aug 2011
Posts: 1
Default 1996 K1500 Transmission Issue

Hi, ive been lurking around here for a while when need be. Im having a problem with my 1996 K1500. It seem that only when traveling on the freeway between 60-70 mph it feels as though either the eingine is every so slightly cutting out, or the transmission is slipping.

I took it to a local AAMCO and they have decieded that it needs a rebuild. He says that the "valve body is toast" and "one of the solenoids" is acting up. Cost of repair? $2350 for a rebuild. Seems like a lotta BS to me. Any input would be appreciated. Thank you guys
This ad is not displayed to registered members.
Register your free account today and become a member on Truckforums!
Reply With Quote
  #2  
Old 08-10-2011, 05:31 PM
NullHead's Avatar
TruckForum Addict
 
Join Date: Apr 2011
Location: Detroit, MI
Posts: 1,039
Default

Perhaps overdrive is failing. Try driving in a non-overdrive gear
Reply With Quote
Old 08-10-2011, 05:31 PM
 
 
 
Reply



Tags
1500, 1996, 6070, 96, aamco, acting, body, chevy, cuts, cutting, k1500, mph, silverado, transmission, trouble, valve

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising

Featured Sponsors
Vendor Directory

Our Sponsors
Advertising
All times are GMT -5. The time now is 05:14 PM.

Internet Brands, Inc.