Go Back   Truck Forums > Chevrolet/GMC Truck Forums > Chevy Silverado/ GMC Sierra Forum
Sign in using an external account
Register Forgot Password?
Search

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 07-19-2005, 10:08 PM
 
Join Date: Jul 2005
Posts: 2
Default Charging system problem

I just bought a new (to me) tow vehicle. Its a 2000 Silverado with the 4.8L and 55K miles. Everything checked out fine, but now my red battery is lighting up intermittently on the dashboard message center. It is supposed to indicate a charging system problem. I tested the battery and the alternator and they look ok. The volt gauge on the dash reads 14v and doesn't move when the light comes on. If I shut the engine off and restart the light will go out. Any ideas? Thanks in advance
This ad is not displayed to registered members.
Register your free account today and become a member on Truckforums!
Reply With Quote
Old 07-19-2005, 10:08 PM
 
 
 
Reply



Tags
2005, 2011, charge, charging, chevrolet, chevy, gmc, issue, problem, problems, sierra, silverado, system, systems, trouble, truck

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising

Featured Sponsors
Vendor Directory

Our Sponsors
Advertising
All times are GMT -5. The time now is 04:44 PM.

Internet Brands, Inc.



SEO by vBSEO ©2010, Crawlability, Inc.