Go Back  Truck Forums > Truck Talk > General Truck Tech
Reload this Page >

2011 International DT MaxxForce 4300, Electrical Problem

General Truck Tech Do you have a question that doesnt apply to a certain make or model, ask it here!

2011 International DT MaxxForce 4300, Electrical Problem

  #1  
Old 12-01-2018, 02:03 PM
Beginner
Thread Starter
Join Date: Dec 2018
Posts: 1
Default 2011 International DT MaxxForce 4300, Electrical Problem

2011 International DT MaxxForce 4300, automatic 171,000 Miles when moving off in D no power it seems as if in 4 speed and need higher rpm just to drive off and no Upshifting or Downshifting when continue to driving down the road electrical fault came on, then RPM and Speedometer Gauge go haywire to the max and the transmission temp gauge goes back to home position 0.

There after a beeping buzzer sound comes on, if you stop and restart at times put it in D or any other speed the transmission would remain as if stuck in 1 speed for a while at very high RPM full throttle no Upshifting or Downshifting but after continue to driving for a while the RPM & Speedometer will drop to normal and the transmission gauge would start to normal reading also Upshifting or Downshifting would work ok no problem however the Temp symbol would start to flash on dash board even there is no sign of overheating the fan seems to be working and coolant level seems ok and then electrical fault will again appear on the dash and the problem started all over again

I had checked the fluids and both the engine oil and Transmission fluid levels seems ok, I had clean power connecter and triple checked all connections. as well as I had a mechanic try to hook up his Truck Diagnostic Tool & Scanner but was able to connect to read any codes for engines, transmissions he said that it could be his software program and will get back with an update to try again, At a loss as where to go from there.

 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Redhead
Classic Trucks
0
10-08-2017 11:54 PM
jasong1645
Commercial Trucks
3
04-23-2015 08:26 PM
NikoKesler
Commercial Trucks
0
03-18-2011 03:52 PM
Helomaniac
Classic Trucks
0
01-31-2009 05:01 PM
MAAR
Commercial Trucks
1
11-07-2008 03:48 PM


Thread Tools
Search this Thread
Quick Reply: 2011 International DT MaxxForce 4300, Electrical Problem


Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.