General Truck Tech Do you have a question that doesnt apply to a certain make or model, ask it here!

Now my 4x4 won't work

  #1  
Old 01-25-2016, 11:37 PM
Beginner
Thread Starter
Join Date: Jan 2016
Posts: 1
Default Now my 4x4 won't work

Help!! Last week I pulled the front drive from my 2005, 2500HD, 6.0, 4x4 to remove the oil pan. That being done I put rod bearings, oil pump and timing chain set. That went well, when done I put everything back together. Then went up top and replaced the belts, knock sensors and harness, with that done, put it all back together. The engine fired right up and runs great, I again have oil pressure. Idle oil pressure is 45 to 50 lbs. Now for my problem, I now have a warning telling me to service the 4x4, I have double checked everything and everything is connected, electrical included. The 4x4 worked just fine before I tore it down. What could I have possible done or missed??????
 
  #2  
Old 07-29-2018, 09:11 PM
Beginner
Join Date: Jul 2018
Posts: 3
Default

Did you unplug a connection?
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
kalabula
Ford Heavy Duty
1
09-24-2011 12:38 PM
TLeid
Chevy Silverado/ GMC Sierra Forum
3
09-04-2011 11:54 AM
Rob234
Chevy Silverado/ GMC Sierra Forum
0
09-11-2010 04:38 PM
daryl
Chevy/GMC Small Trucks Forum
8
09-10-2008 04:32 AM
akcolby
Chevy Silverado/ GMC Sierra Forum
1
04-20-2006 12:23 PM


Thread Tools
Search this Thread
Quick Reply: Now my 4x4 won't work


Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.