2006 Chevy 2500hd 8.1L 4x4 Allison Transmission Problems **PLEASE HELP** - Truck Forums


Chevy/GMC Heavy Duty Discuss your 2500 and 3500 Chevy and GMC pickups as well as the DURAMAX diesel and it's predecessors

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 07-31-2018, 12:53 AM
Beginner
Thread Starter
 
Join Date: Jul 2018
Posts: 1
Default 2006 Chevy 2500hd 8.1L 4x4 Allison Transmission Problems **PLEASE HELP**

Here goes, transmission will not engage in any gear currently.

I bought this truck a couple weeks back with knowing it had intermittent Limp mode issues. I bought it and drove it approximately 150 miles home. During which it got in the 250 to 260 range and was goin in and out of limp mode probably a dozen or so times. It would decelerate to approximately 50-55 mph like it was in 3rd gear and then would allow me to accelerate to 65-75mph and then cycle thru and repeat the process of limp mode as described. The CEL came on but I did not have a reader at the time. Finally after getting home I parked it and started it next morning and read all the codes; P0700, p0761, p0756, p0751, p0877, p0873, p0848, p0843, p0732 and p0762. I cleared the codes and did a complete oil and filter(internal and external) change. Confirmed the correct fluid level at operating temperature, however when it gets hot the level is extremely high on the dip stick above the hotxxx.

After completing that I still was getting codes P0700, p0751, p0761 and p0877. I have checked the connection at the transmission and at the TCM and didn’t find any problems. I checked ALL the fuses and didn’t find any problems. I also applied dialectric greese on both the TCM and transmission harness to ensure a proper conductivity but that has not helped. Also started having problems while driving it around the block with it coming out of gear and had to wait until the trans cooled down to have it able to go back into gear. Seems like it has progressively gotten worse as now it is no longer going into gear at all after blowing out the trans cooler lines.

As of late I took it and blew the transcooler lines out to ensure no blockage however now it has come up several times coming up as “shift range inhibited” and will not go into gear at all. I’ve also had the digital display on the dash stop working after it gets upto normal operating temperature 2 times now.

ANY SUGGESTIONS? Could it be the internal mode switch (IMS) that has gone bad? Or is it the TCM? Both I’ve heard are not common problems but this seems like an electronica issue..

please any help on this would be greatly appreciated....

Last edited by Phatty; 07-31-2018 at 09:15 AM.
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2006 GMC 2500HD 6.0L gas Transmission cooler lines mjn030 Chevy Silverado/ GMC Sierra Forum 0 07-21-2009 08:48 AM
NEW PRICE!! 2006 2500HD 4x4 crew dmax 6spd allison LOADED 1st $33K no offers saandman Vehicles for Sale 2 01-21-2008 07:48 PM
Allison? montyburns Chevy Silverado/ GMC Sierra Forum 5 11-02-2007 08:35 PM
Changing atf on allison 1000... Freeman02081985 Chevy Silverado/ GMC Sierra Forum 1 08-12-2007 02:26 PM
allison trans. tml Chevy Silverado/ GMC Sierra Forum 2 04-15-2007 10:17 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Featured Sponsors
Vendor Directory

All times are GMT -5. The time now is 11:06 AM.


© 2018 MH Sub I, LLC dba Internet Brands
We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.