Ford General Tech Ford tech talk within.

New to this, truck running rough

  #1  
Old 10-14-2012, 02:18 PM
Beginner
Thread Starter
Join Date: Oct 2012
Posts: 1
Default New to this, truck running rough

Im new to this Forum. I am having problems with my 1988 Ford Bronco II, it has a 2.9L v6 engine. It runs fine when I start it up, but once it warms up after 5 minutes or so, it starts to run rough and idles rough. Nomral idle for it is just above 1000 rpm, but running rough it stays under 1000 to 500 and just goes back and forth. After a minute or so its back to normal running conditions. When driving it will do the same thing ever so often and it will have no power to it what so ever. I am thinking it may be a vac leak, but im not to sure or where to start looking for the problem. Thank you.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
03RAMREGCAB
Dodge/ Ram 1500 Forum
0
09-12-2009 10:36 PM
akohnz
Chevy Silverado/ GMC Sierra Forum
9
02-15-2009 09:15 AM
drradon
Chevy Silverado/ GMC Sierra Forum
4
10-25-2008 08:47 AM
dtrain
Chevy/GMC Small Trucks Forum
4
02-16-2008 02:29 PM
Marki
Chevy/GMC Small Trucks Forum
1
11-28-2006 12:52 PM


Thread Tools
Search this Thread
Quick Reply: New to this, truck running rough


Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.