General Motors Tech Chevy tech talk within.

1992 Chevy 1500 Idle Problems

  #1  
Old 04-08-2013, 12:24 AM
TNT1500's Avatar
Beginner
Thread Starter
Join Date: Apr 2013
Posts: 5
Default 1992 Chevy 1500 Idle Problems

I have a 1992 Chevy 1500 with the 5.7L Tbi in it. I recently had to replace my head gaskets and now have have a rough idle. It seems to idle ok when im in park but when i go to drive or reverse the truck will start to shake and idle pretty rough. As soon as i give it a little gas it levels off, idle comes up to about where it should be. Anyone have any clue what it could be?
 
  #2  
Old 04-08-2013, 07:49 AM
In2Trux's Avatar
Administrator
Join Date: Feb 2010
Location: Northern Ont
Posts: 1,743
Default

O2 sensor
Check for codes
 
  #3  
Old 04-08-2013, 09:35 AM
TNT1500's Avatar
Beginner
Thread Starter
Join Date: Apr 2013
Posts: 5
Default

i dont have a check engine light on, and last time i checked there were no codes. when im at at stop in drive when it idles it almost sounds like a lope or like it has a bigger cam in it, which it doesnt.
 
  #4  
Old 04-09-2013, 07:57 AM
ItBeMe's Avatar
Senior Member
Join Date: Jul 2010
Location: On planet earth & in Hotlanta Ga.
Posts: 161
Default

May be a vacuum leak.
 
  #5  
Old 04-09-2013, 08:36 AM
TNT1500's Avatar
Beginner
Thread Starter
Join Date: Apr 2013
Posts: 5
Default

yea thats kind of what i was thinking...i havent looked over all the vacuum lines yet. also i plan to put vacuum to my EGR to make sure it is working because i was told that could cause it too.
 
  #6  
Old 06-29-2014, 11:55 PM
Beginner
Join Date: Jun 2014
Posts: 1
Default

Originally Posted by TNT1500 View Post
I have a 1992 Chevy 1500 with the 5.7L Tbi in it. I recently had to replace my head gaskets and now have have a rough idle. It seems to idle ok when im in park but when i go to drive or reverse the truck will start to shake and idle pretty rough. As soon as i give it a little gas it levels off, idle comes up to about where it should be. Anyone have any clue what it could be?
I had the same trouble I even replaced the spark plugs, fuel filter and spark plug cables.
It turned out to be my distributor cap
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Big Armadillo
New Member Area
4
12-10-2014 10:32 PM
Chevyalltheway
Chevy Silverado/ GMC Sierra Forum
24
09-18-2008 01:41 AM
92chevy1500
General Motors Tech
2
03-29-2008 07:26 AM
zamaro
Chevy Silverado/ GMC Sierra Forum
2
01-30-2007 08:08 AM


Thread Tools
Search this Thread
Quick Reply: 1992 Chevy 1500 Idle Problems


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.