General Motors Tech Chevy tech talk within.

5-speed manual transmission problem

  #1  
Old 11-24-2012, 08:24 PM
Beginner
Thread Starter
Join Date: Nov 2012
Posts: 1
Default 5-speed manual transmission problem

I have a 1995 chevy k1500 with a 305 5 speed manual transmission. the other day driving at hwy speed, my transmission lost power and now all that I get is a grinding sound, but when the clutch pedal is depressed no sound until I start to engage the clutch. That is when I get the grinding sound. Any help would be great.
 
  #2  
Old 11-24-2012, 09:20 PM
RustyFordLover's Avatar
Senior Member
Join Date: Jul 2012
Location: Fairbanks Alaska
Posts: 492
Default

Sounds like you need a new clutch.
 
  #3  
Old 11-25-2012, 11:37 AM
In2Trux's Avatar
Administrator
Join Date: Feb 2010
Location: Northern Ont
Posts: 1,743
Default

You've either dickered your clutch or the main in your tranni

Welcome to Truck Forums. Sorry to hear about your truck prob. It's too bad this is what it took for you to become a member.
Hope you can stick around and become a regular member here
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
mic_in_chevy
Chevy Silverado/ GMC Sierra Forum
16
08-14-2014 05:36 PM
humble_SEVEN
New Member Area
2
10-09-2011 09:50 PM
cowboy3008
Chevy Silverado/ GMC Sierra Forum
1
07-08-2010 05:20 PM
1986454
General Motors Tech
0
03-28-2009 09:11 PM
00_slammmed
Chevy Silverado/ GMC Sierra Forum
4
12-22-2006 07:58 AM


Thread Tools
Search this Thread
Quick Reply: 5-speed manual transmission problem


Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.