General Motors Tech Chevy tech talk within.

Thermostat or sending unit.

  #1  
Old 02-12-2011, 01:09 PM
Junior Member
Thread Starter
Join Date: Feb 2011
Location: Western Colorado
Posts: 3
Default Thermostat or sending unit.

This one shouldn't be too hard, 2000 Tahoe Z71, 5.7 vortec, temp gage never goes much past 100* ,good heat coming from vents, Sending unit or thermostat? or just replace both?

Thanks
 
  #2  
Old 02-12-2011, 09:52 PM
Junior Member
Join Date: Feb 2011
Posts: 4
Default

try the thermostat first. had the same prob with my 93 chev pu with 4.3 and also with my nissan sentra. thermostat fixed both of them.heaters work a lot better!you could borrow one of those laser thermoeters and just remove the rad cap and shoot the coolant and see what the temp is.that right there would tell ya.
 
  #3  
Old 02-21-2011, 02:59 PM
Junior Member
Thread Starter
Join Date: Feb 2011
Location: Western Colorado
Posts: 3
Default

Yep, changed the thermostat & now it's running right at 190*.
Thanks.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
hotrod650
General Motors Tech
4
10-24-2013 05:43 PM
dsmwookie
Chevy Silverado/ GMC Sierra Forum
2
12-14-2010 09:14 PM
Tomasm87
General Motors Tech
0
09-05-2010 12:37 PM
sarge150
New Member Area
0
02-26-2007 09:53 PM
mquality55
Automotive Parts for sale
0
01-18-2007 01:19 PM


Thread Tools
Search this Thread
Quick Reply: Thermostat or sending unit.


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.