General Truck Tech Do you have a question that doesnt apply to a certain make or model, ask it here!

1989chevy2500k4x4 5.7 electrical problem

  #1  
Old 06-21-2016, 04:34 PM
Beginner
Thread Starter
Join Date: Jun 2016
Posts: 3
Default 1989chevy2500k4x4 5.7 electrical problem

Can anybody help please. Got a 89 Chevy 2500k 5.7tbi
With electrical issue. Rebuild engine and install
While installing the wire harness I found 3 ring terminals
1 for the alternator, 2 ground on the thermostat housing, 3 seems like a ground but when I turn the key on it powers up.
I attached a picture hopefully some one can help me thanks
 
Attached Thumbnails 1989chevy2500k4x4 5.7 electrical problem-image.jpeg  
  #2  
Old 06-21-2016, 10:54 PM
Junior Member
Join Date: May 2014
Posts: 96
Default

the alternator should have one red and one brown wire going to it. if you pull the 20amp gauge fuse go the mystery wire lose power?
 
  #3  
Old 06-22-2016, 01:57 PM
Beginner
Thread Starter
Join Date: Jun 2016
Posts: 3
Default

Hello. thanks for the help.
Yes when I remove the 20 amp fuse it still has power
And it only gets power wen I turn the key on.
For the alternator it has 2 cables one red and the brown one in a weather head type connector
When I power probe the ring connector in question, it triggers the temp gauge, starter solenoid, cruise control box and a relay on the fire wall. Question
I took off the ground cable on the thermostat housing and turn the key on and the ground is also getting power. To my small knowledge a ground cable should be ground not have any power what so ever runing through it . But I never had a Chevy truck. Thanks in Advance for any help given
 

Last edited by Sosa81; 06-24-2016 at 05:00 PM.
  #4  
Old 06-25-2016, 09:13 PM
Beginner
Thread Starter
Join Date: Jun 2016
Posts: 3
Cool

So I trace the wiring and found that the black/white stripe cable has power. When the key is on accessory. Is there any body out there who has some knowledge on the 89 Chevy 2500k 4x4 5.7tbi. Electrical.
Is there any place where the black with white stripe might be in contact with a power source?
����������
Ok so I found where the ring connector goes to.
It is another ground cable. Now. I know that ground cables are not supposed to have power
I get 9.9v when I turn the key on and if I turn the key off the cable power lingers until grounded
So I went to the fuse box and removed all fuses and found that the ign-ecm is the one that powers it. Has anybody had this problem or can you shine some light on the issue
 

Last edited by Sosa81; 07-02-2016 at 01:25 PM.
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
sickshoesbrah
General Motors Tech
2
03-09-2007 06:26 PM
chevyguy#1
General Motors Tech
3
02-25-2007 04:45 PM
Mcfish
Chevy Silverado/ GMC Sierra Forum
0
11-30-2006 12:46 AM
quadracer
General Motors Tech
1
02-16-2006 08:41 PM
chrisselfz71
Chevy Silverado/ GMC Sierra Forum
2
11-15-2005 09:36 PM


Thread Tools
Search this Thread
Quick Reply: 1989chevy2500k4x4 5.7 electrical problem


Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.