New Member Area Are you new? WELCOME! Check in, tell us about yourself and your ride.

New here!

  #1  
Old 05-09-2019, 06:06 PM
Beginner
Thread Starter
Join Date: May 2019
Posts: 1
Default New here!

Hello! I'm new here and have a question. I have a 1997 Chevy K1500 with the 5.7L. I've had the truck for about 6 years and have gone through 4 fuel pumps so far, from my research it's just a design flaw... I thought my fuel pump had gone out on me again, so I took the short route and replaced the relay, no luck so I dropped the tank and replaced the pump but still no luck... I took the ground for the pump off and sanded it down to take the surface rust off, sanded the frame where the bolt goes through, and put a new bolt in all together... still nothing. The pump won't spin up and I have no pressure to the fuel rail(obviously). It has a brand new battery and I did a total motor rebuild about a year ago. Any ideas what I can try next?? I'm at my whits end with it... :/
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
flynhghr2001
New Member Area
0
01-05-2010 08:22 PM
DennisT
Chevy Silverado/ GMC Sierra Forum
2
03-24-2009 09:59 AM
rxsteven
Off Topic
6
04-08-2008 10:10 PM
wpgWiggum
New Member Area
2
07-22-2006 01:36 PM
BlueKnight
New Member Area
0
03-05-2006 11:20 PM


Thread Tools
Search this Thread
Quick Reply: New here!


Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.