03 silverado tranny slip

  #1  
Old 03-06-2013, 10:13 PM
Beginner
Thread Starter
Join Date: Mar 2013
Posts: 3
Default 03 silverado tranny slip

So my tranny was driving perfect till today still has full fluid no leaks but its slipping in third gear and overdrive and if you get on it in second. It still moves just not well. It seems to be all done but I was just wondering if theres any sensors or anything that might cause this. Anyone experiance this?
 
  #2  
Old 03-07-2013, 08:02 AM
In2Trux's Avatar
Administrator
Join Date: Feb 2010
Location: Northern Ont
Posts: 1,743
Default

A little more info... is this the 03 Duramax with the 1000 Allison transmission???
 
  #3  
Old 03-08-2013, 12:06 PM
Beginner
Thread Starter
Join Date: Mar 2013
Posts: 3
Default

Its the 4.8. Single cab short bed. 130,000 miles. I thought it might be a sensor because the tow/haul button is not showing working and it was the day before
 
  #4  
Old 03-08-2013, 09:07 PM
In2Trux's Avatar
Administrator
Join Date: Feb 2010
Location: Northern Ont
Posts: 1,743
Default

Try pulling the tranni dip stick and SMELL it.
If it smells some what BURT I'm sure you can guess what your problem is.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
rupedogg
General Motors Tech
0
05-04-2011 07:56 AM
buckman
Chevy Silverado/ GMC Sierra Forum
1
03-09-2008 08:39 AM
sknaffl
Chevy Silverado/ GMC Sierra Forum
18
12-03-2007 03:54 PM
stopspazinout
Chevy Silverado/ GMC Sierra Forum
16
07-20-2007 07:00 AM
4jeepnuts
General Motors Tech
2
09-01-2006 11:15 AM


Thread Tools
Search this Thread
Quick Reply: 03 silverado tranny slip


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.