89 K1500 TBI no spark when warm

  #1  
Old 06-18-2016, 04:47 PM
Beginner
Thread Starter
Join Date: Jun 2016
Posts: 2
Question 89 K1500 TBI no spark when warm

I hope I find some help here as this problem has all of the mechanic shops and dealerships in this area stumped. When cold this truck starts and runs fine. I can drive it to town or for several hours and it runs fine but within 30 minutes of sitting it has no spark. If you let it set overnight and cool completely down it starts and runs great until it has warmed up good then when shut off for less than 30 minutes, no spark again. The coil, cap, rotor, ignition module have all been replaced. Am replacing the pick up coil in the distributor next. Also has a brand new battery. It seems like some electrical component under the hood is the problem and it really acts like a circuit breaker that resets after cooling down. I have looked at wiring diagrams and cannot see any ignition relays or circuit breakers in the engine compartment that could be the problem. Also none of these mechanics seem to know how to read the trouble codes even the dealerships. I have an old Chilton's manual that has the codes listed and the procedure for reading them but it is for an 87 model and I am not sure they will be the same. You have to watch the service engine light blink and I just don't think these mechanics have the patience to do that even though I am the one paying the bill ha ha. I am quite a bit of money into this already and if replacing the pickup coil doesn't fix it I am bringing it home to work on it myself. Anybody have any ideas???
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
95plugwire
Chevy Silverado/ GMC Sierra Forum
6
03-29-2012 08:54 PM
dearborn2415
Chevy Silverado/ GMC Sierra Forum
1
10-25-2011 03:45 PM
ryan penn
Report Concerns, Make Suggestions, & Get Help Using The Forum
0
02-03-2011 06:22 PM
probingyou
Chevy Silverado/ GMC Sierra Forum
2
08-18-2009 02:48 AM
Thraxxx
Chevy Silverado/ GMC Sierra Forum
4
10-22-2007 04:31 PM


Thread Tools
Search this Thread
Quick Reply: 89 K1500 TBI no spark when warm


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.