Ford F-150 Forum Discuss the Ford F-150 here.

4x4 and speedo wont work??

  #1  
Old 09-19-2010, 04:00 PM
Junior Member
Thread Starter
Join Date: Sep 2010
Posts: 1
Default 4x4 and speedo wont work??

(f150 2007 xlt 4.6L) Hey guys, new to this forum... I've been pretty lucky with my truck, so far. So I washed my undercarriage of my truck with a pressure washer and I drove it about an hour later and noticed that the 4x4 high light was on so i turned it to 2wd. Sadly the light wouldnt turn off but it was in 2 wheel drive. Now when i switch it back to 4 high i don’t hear the hubs locking and the light is still on and its still in 2wd. Also my speedo stopped working as well at the same time... could they be related?

Could it be a loose connection on the bottom of the truck? or did i maybe blow a fuse? I did check the fuses that were related to the 4x4 (i checked the main fuses).

Any kind of answer guys would be a big help.
 

Last edited by Eff1Fifttah; 09-19-2010 at 05:37 PM.
  #2  
Old 10-07-2010, 06:04 AM
Banned
Join Date: Jul 2010
Posts: 22
Default

check the wiring on the back of the dash unit sometimes those will give problems and cause the speedometer not to work right,if not you may have a bad speedometer head on it,good luck.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
kalabula
Ford Heavy Duty
1
09-24-2011 12:38 PM
stumped
Silverado/Sierra FAQs
3
02-10-2011 09:17 PM
1killakella
General Motors Tech
1
12-12-2010 03:06 PM
dmccartyfan
Chevy Silverado/ GMC Sierra Forum
6
06-16-2010 06:38 PM
sbrrdnk
Toyota Tundra
0
01-26-2008 09:07 PM


Thread Tools
Search this Thread
Quick Reply: 4x4 and speedo wont work??


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.