Ford General Tech Ford tech talk within.

oil pump?

  #1  
Old 12-31-2007, 08:37 AM
Thread Starter
Join Date: Dec 2007
Posts: 2
Default oil pump?

So I have a 2000 F250 Super Duty w/ V10. It has 67k miles on it atm. I have had no problems with it in the past 5 months I have had it. Yesterday I get in and drive 1/4 mile down the road and my oil lightcomes on, and I look and have no oil pressure. This happened as I got up to around 55mph ( maybe 2700 rpm) once I slowed down the oil light went off and my pressure back up. I pulled over, simulated in park just by reving it up and it did the same thing- high rpm,I lost all oil pressure and light came on, it went off when truck went back to idle. My oil level is fine. I am guessing either new pump or is it possible to have sensor bad? Is it connected to the gauge as well, or are they separate? (both warning light and gauge). Any help will be most appreciative.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
In2Trux
Chevy Silverado/ GMC Sierra Forum
0
04-19-2015 08:50 PM
ecarri100
Ford Heavy Duty
7
01-09-2011 09:54 AM
chrisbmo2000
Chevy Silverado/ GMC Sierra Forum
5
12-24-2010 03:35 PM
Juice
Chevy Silverado/ GMC Sierra Forum
2
05-21-2009 08:46 PM
Marty
Chevy Silverado/ GMC Sierra Forum
1
10-23-2007 05:26 AM


Thread Tools
Search this Thread
Quick Reply: oil pump?


Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.