General Motors Tech Chevy tech talk within.

Chevy 7.4L engine Electrical problem. Burnt wire.

  #1  
Old 02-13-2012, 09:45 AM
Beginner
Thread Starter
Join Date: Feb 2012
Posts: 1
Default Chevy 7.4L engine Electrical problem. Burnt wire.

Hello,
I have a 1994 Winnebago Adventurer built on a Chevy P30 frame with 7.4L engine. While driving down the highway on cruise control at 55MPH, the engine stopped and all electrical power ceased. Smoke came out around the engine. There was a strong smell of electrical wire burning.
It's the green wire in the group of 4 wires (red, pink, black, green) ran over the top of the transmission into transmission cable control box mounted onto the frame. I don’t know what those wires are for but if I disconnect them the transmission won’t go into gears. Does anybody have had this problem before? What is the cause for the green wire to melt down? Please help. Thanks.
Please see the pictures at this link.
http://www.use.com/editset.pl?set=d0a2fbb2e432b8a34c88
 
Attached Thumbnails Chevy 7.4L engine Electrical problem. Burnt wire.-1-green-wire-burnt.jpg   Chevy 7.4L engine Electrical problem. Burnt wire.-1-green-wire-2.jpg  

Last edited by viet1; 02-13-2012 at 12:33 PM.
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Mike460Hall
Ford Heavy Duty
0
12-12-2011 01:58 PM
cubpak89
Chevy Silverado/ GMC Sierra Forum
0
08-06-2011 04:25 PM
chrisbmo2000
Chevy Silverado/ GMC Sierra Forum
5
12-24-2010 03:35 PM
adamant
Chevy Silverado/ GMC Sierra Forum
3
02-01-2009 06:39 PM
kkcolt4
Toyota Tundra
3
12-18-2008 04:41 AM


Thread Tools
Search this Thread
Quick Reply: Chevy 7.4L engine Electrical problem. Burnt wire.


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.