General Motors Tech Chevy tech talk within.

Dead spot in throttle

  #1  
Old 12-20-2011, 04:02 PM
Junior Member
Thread Starter
Join Date: Sep 2011
Posts: 1
Default Dead spot in throttle

I have an 02 GMC Savana 5.7 4L80E 3.73. I have replaced the fuel pump and filter. Done the central port to multi port conversion with a new regulator. Checked the cap, rotor, wires and plugs all looks fine there. It is not throwing any codes.
I have a dead spot in the throttle. When I go to accelerate it goes fine if I am light on the gas but as I increase throttle pressure the output does not equal the input. It goes flat for a good portion of throttle travel about 15% to 70% and then starts to equal out. I have no power at all ever. Not off idle or WOT or anywhere in-between. Heaven forbid I have to start off on a hill.
Does the TPS go bad on these? Can I put an OHM meter on it and what should it read?
I am only getting 8MPG. Can someone please help?
 

Last edited by 02Savana; 12-20-2011 at 04:59 PM.
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Belesari
Ford Heavy Duty
8
04-17-2013 03:56 PM
shep
General Motors Tech
4
07-12-2011 10:04 AM
jcook
Chevy Silverado/ GMC Sierra Forum
2
03-20-2008 11:07 AM
benjoeau02
Off Road
0
01-15-2008 09:07 PM
Trekerjohn
Chevy Silverado/ GMC Sierra Forum
3
10-29-2006 02:22 AM


Thread Tools
Search this Thread
Quick Reply: Dead spot in throttle


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.