General Motors Tech Chevy tech talk within.

Sputtering while accelerating

  #1  
Old 05-15-2010, 08:54 PM
Junior Member
Thread Starter
Join Date: May 2010
Posts: 6
Default Sputtering while accelerating

I have a 98 K1500 5.7L and when I accelerate under a load it spits and sputters. It threw a code for an oxygen sensor so I replaced that and now its throwing a Throttle Position Sensor code. I have checked the timing, replaced the fuel filter and MAF, and checked all the plug wires. Could the TPS cause it to do what its doing by possibly messing with the air to fuel ratio? I'm going to replace the TPS but if that doesn't fix it what else could it be? I appreciate the help and advice.
 
  #2  
Old 06-19-2010, 07:53 AM
Junior Member
Join Date: Jun 2010
Posts: 10
Default

sounds like a spark issue I would power brake (load) the engine at ur missing rpm and watch for spark arcing
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
bagged_b2600
Ford Ranger/ Mazda B-Series
4
11-26-2013 10:30 AM
geomath
Ford Heavy Duty
0
09-19-2010 02:19 PM
lebanontn
Chevy Silverado/ GMC Sierra Forum
3
09-07-2009 11:23 AM
jm7777
Chevy Silverado/ GMC Sierra Forum
0
07-26-2007 05:53 PM
sclaymore
Chevy Silverado/ GMC Sierra Forum
1
10-15-2006 02:08 AM


Thread Tools
Search this Thread
Quick Reply: Sputtering while accelerating


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.