General Motors Tech Chevy tech talk within.

94 chevy 1500, Electrical problem.

  #1  
Old 07-22-2011, 09:06 PM
Junior Member
Thread Starter
Join Date: Jul 2011
Posts: 1
Default 94 chevy 1500, Electrical problem.

Hey guys, I have a 1994 chevy 1500 z71 5.7l, And I'm pretty sure I have a wiring issue, a bad ground or a short somewhere. When I turn on the truck, The battery meter will be at about 12-14volts. When I turn on my headlights, It will drop to about 10. Whenever I try to roll my windows down (power windows) It'll drop about 2-3volts the whole time. Having my AC on will also but the battery down to 9volts. Whenever I put it in gear, It drops to about 9-10. Whenever it drops really low, my radio will keep turning off/on and my windshield wipers will keep going. I thought it might have been the battery, So I bought a new one, And it still dose it. I had Autozone check my alternator and they said it was good. They checked The ground cable and positive cable coming from the battery and said they both were in good condition. So I'm completely lost, Could anyone try to help please?
 
  #2  
Old 07-25-2011, 11:25 AM
Junior Member
Join Date: Jul 2011
Posts: 8
Default

i had this same problem on an older chevy car (can't remember what year or make). it turned out to be a wire from the starter to the alt. like i said it was an older vehicle so i would start by checking the wiring at the starter and then work my way up to the alt and battery. hope this kinda helps.
 
  #3  
Old 09-15-2011, 02:58 AM
Junior Member
Join Date: Sep 2011
Posts: 2
Default

Im having a similar problem with my 95 2500. When iturn my lights on they flicker and drain my battery alittle bit and i hear a humming noise when the trucks running. Im thinking its a short but i dont know where. Any help would be greatly appreciated.
 
  #4  
Old 09-15-2011, 08:12 AM
Mr_Shamrock's Avatar
Chevrolet/GMC, Racing, Recreational Forum Moderator
Join Date: Apr 2009
Posts: 2,267
Default

Originally Posted by ShadowBound View Post
Im having a similar problem with my 95 2500. When iturn my lights on they flicker and drain my battery alittle bit and i hear a humming noise when the trucks running. Im thinking its a short but i dont know where. Any help would be greatly appreciated.
I would have the alternator checked. They can make a humming noise when they are going bad.
 
  #5  
Old 10-13-2011, 04:02 AM
Junior Member
Join Date: Sep 2011
Posts: 2
Default

i changed my alt and everything is fine. Thank you for the help.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
viet1
General Motors Tech
0
02-13-2012 09:45 AM
THIERRY
Chevy Silverado/ GMC Sierra Forum
1
05-17-2011 08:39 PM
Mcfish
Chevy Silverado/ GMC Sierra Forum
0
11-30-2006 12:46 AM
quadracer
General Motors Tech
1
02-16-2006 08:41 PM
chrisselfz71
Chevy Silverado/ GMC Sierra Forum
2
11-15-2005 09:36 PM


Thread Tools
Search this Thread
Quick Reply: 94 chevy 1500, Electrical problem.


Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.